CVE-2026-116695: rubygem-crass security update
Affects rubygem-crassSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.0.8-1.oe2203sp4 when convenient.
Data as of 4 Nov 2026, 16:47 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 5.3 |
|---|
- Patch
- Available – fixed in 1.0.8-1.oe2203sp4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade rubygem-crass to 1.0.8-1.oe2203sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 22.03-LTS-SP4rubygem-crasspkg:rpm/openEuler/rubygem-crass&distro=openEuler-22.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade rubygem-crass to version 1.0.8 or later, which includes fixes for all described vulnerabilities. Versions 1.0.7 and 1.0.8 introduce recursion depth limits and correct parsing logic to prevent denial of service and CSS injection issues. No additional mitigation is required if updated to these versions.
Description
Multiple security vulnerabilities affect rubygem-crass, a Ruby CSS parser compliant with CSS Syntax Level 3. Prior to version 1.0.8, Crass incorrectly handles closing parentheses after escaped backslashes in bad URLs, potentially allowing CSS-based UI redress or data exfiltration, though not script execution. Versions before 1.0.7 suffer from unbounded recursion in parsing nested CSS blocks and functions, leading to denial of service via stack overflow or excessive memory use. Additionally, recursive comment parsing and inefficient handling of non-ASCII characters can cause excessive CPU consumption or crashes. These issues are fixed in versions 1.0.7 and 1.0.8.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4725 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-116695 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61846 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61847 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61848 (opens in a new tab)