CVE-2026-42189: Rust russh · Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in
Affects rust-russhSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 0.60.1 : patch rust-russh soon.
Data as of 27 Oct 2026, 03:30 UTC
- Patch
- Available – fixed in 0.60.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rust-russhpkg:deb/ubuntu/rust-russh?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade russh to version 0.60.1 or later, where this denial-of-service vulnerability has been patched.
Description
Rust russh versions prior to 0.60.1 contain a pre-authentication denial-of-service vulnerability in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server implementing keyboard-interactive authentication with a single malformed packet without needing credentials. This vulnerability has been fixed in version 0.60.1.