Skip to main content
VulnerabilityPublished Updated

CVE-2026-42189: Eugeny russh · Unthrottled Resource Allocation

Affects Eugeny russhSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.60.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.60.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade russh and github/eugeny/russh to 0.60.1.

Affected software

ProductAffectedFixed in
EugenyrusshAffected
  • <0.60.1
Fixed in
  • 0.60.1
crates.iogithub/eugeny/russhpkg:cargo/github/eugeny/russhOther threatsAffected
  • <0.60.1
Fixed in
  • 0.60.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in russh version 0.60.1. Users of russh should upgrade to version 0.60.1 or later to remediate this issue. Patch status is not explicitly stated in the vendor advisory content, but the description confirms the fix is included in version 0.60.1. No additional mitigations are indicated.

Description

Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.

References

Community reviews

Loading reviews…