CVE-2025-53901: Rust wasmtime · Wasmtime is a runtime for WebAssembly
Affects rust-wasmtimeSource GCVE Database
Not known to be exploited · CVSS 3.5 Low.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 25.10rust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Wasmtime versions 24.0.4, 33.0.2, or 34.0.2 or later to resolve this issue. There is no workaround for affected embeddings that provide guests with the ability to open multiple file descriptors. Embedders using WASIp2 or components, or those not allowing guest file descriptor creation, are not affected and do not require action.
Description
A bug in Wasmtime's WASIp1 implementation can cause a panic in the host runtime when a WebAssembly guest calls fd_renumber with certain arguments followed by path_open. This leads to a denial-of-service condition but does not cause memory corruption or sandbox escape. The issue affects Wasmtime versions prior to 24.0.4, 33.0.2, and 34.0.2 and requires the guest to have access to open multiple file descriptors, typically via a preopened directory. No workaround exists other than updating to a patched version.
References
- ubuntu.com/security/CVE-2025-53901 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-53901 (opens in a new tab)
- github.com/bytecodealliance/wasmtime/security/advisories/GHSA-fm79-3f68-h2fc (opens in a new tab)
- docs.wasmtime.dev/security-what-is-considered-a-security-vulnerability.html (opens in a new tab)
- docs.wasmtime.dev/stability-release.html (opens in a new tab)
- github.com/bytecodealliance/wasmtime/blob/037a6edadbc225decbea00a551aabf04203717d9/crates/wasi/src/preview1.rs (opens in a new tab)
- github.com/WebAssembly/WASI/blob/e1aa1cae4dda4c1f70f23fe11e922aae92f240a8/legacy/preview1/witx/wasi_snapshot_preview1.witx (opens in a new tab)