CVE-2026-34987: Rust wasmtime · Wasmtime is a runtime for WebAssembly
Affects rust-wasmtimeSource GCVE Database
Not known to be exploited · CVSS 9.0 Critical · fixed in 36.0.7 : patch rust-wasmtime as a priority.
Data as of 5 Nov 2026, 00:01 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 36.0.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10rust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Wasmtime to version 36.0.7, 42.0.2, or 43.0.1 or later, where this vulnerability is fixed. Avoid using the Winch compiler backend (-Ccompiler=winch) if possible, as the default Cranelift backend is not vulnerable. No other mitigation is indicated by the vendor advisory.
Description
Wasmtime, a runtime for WebAssembly, contains a critical vulnerability in its Winch compiler backend versions from 25.0.0 up to but not including 36.0.7, 42.0.2, and 43.0.1. This flaw allows a guest Wasm module to access host memory outside its sandbox, potentially leading to data leaks, denial of service, or remote code execution. The vulnerability requires the non-default Winch compiler to be used, as the default Cranelift backend is not affected. The issue arises from incorrect assumptions about memory offset handling in 64-bit registers. Fixes are available in versions 36.0.7, 42.0.2, and 43.0.1.