Skip to main content
VulnerabilityPublished Updated

CVE-2024-6345: Sceptre · setuptools vulnerable to Command Injection via package URL

Affects sceptreSource GCVE Database

0
Authoritative record:CVE-2024-6345· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 4.4.2_3 soon.

Data as of 26 Oct 2026, 18:58 UTC

CVSS 3.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.4.2_3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade sceptre to 4.4.2_3.

Affected software

ProductAffectedFixed in
Homebrewsceptrepkg:brew/sceptreOther threatsAffected
  • >=4.4.2 <4.4.2_3
Fixed in
  • 4.4.2_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability in the `package_index` module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.

References

Community reviews

Loading reviews…