Skip to main content
VulnerabilityPublished Updated

CVE-2025-58367: Sceptre · DeepDiff Class Pollution in Delta class leading to DoS, Remote Code Execution, and more

Affects sceptreSource GCVE Database

0
Authoritative record:CVE-2025-58367· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 4.5.3_4 as a priority.

Data as of 27 Oct 2026, 23:13 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.3_4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade sceptre to 4.5.3_4.

Affected software

ProductAffectedFixed in
Homebrewsceptrepkg:brew/sceptreOther threatsAffected
  • >=2.7.0 <4.5.3_4
Fixed in
  • 4.5.3_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in DeepDiff version 4.5.3_4. Users should upgrade to this version or later to remediate the vulnerability. No other mitigations are specified by the vendor advisory. Until patched, avoid deserializing untrusted input with the Delta class.

Description

CVE-2025-58367 is a critical vulnerability in the DeepDiff Python library's Delta class that allows class pollution via its constructor. This flaw can be exploited to modify the internal allow list for safe deserialization, enabling insecure Pickle deserialization and potentially leading to remote code execution. The vulnerability also enables denial of service by corrupting built-in classes. A patch is available in version 4.5.3_4.

References

Community reviews

Loading reviews…