Skip to main content
VulnerabilityPublished

CVE-2026-122075: Scheduler · This module enables you to schedule content to be published or unpublished at a certain

Affects drupal/schedulerSource GCVE Database

0
Compare

Not known to be exploited · fixed in 2.3.1 : update drupal/scheduler when convenient.

Data as of 4 Nov 2026, 21:55 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 2.3.1, 2.2.3, 2.2.0 +2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/schedulerAffected
  • <1.7.0
  • >=2.2.0 <2.2.3
  • >=2.0.0 <2.1.0
  • >=2.1.0 <2.2.0
  • >=2.3.0 <2.3.1
Fixed in
  • 1.7.0
  • 2.2.3
  • 2.1.0
  • 2.2.0
  • 2.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the available patches by upgrading to one of the fixed versions: 1.7.0, 2.1.0, 2.2.0, 2.2.3, or 2.3.1. Since a patch is available, remediation should be performed promptly. No additional mitigation steps are indicated beyond applying the official fixes.

Description

The Drupal Scheduler module has a vulnerability where it does not properly verify user permissions when changing publication or unpublication dates. This can lead to content being published earlier or unpublished later than intended. The issue requires the attacker to already have edit permissions on the content and the content must be editable via web services APIs such as JSON:API or REST. Fixed versions are available.

References

Community reviews

Loading reviews…