Skip to main content
CVE-2026-122058VulnerabilityPublished

drupal/simple_oauth · Simple oauth: This module introduces an OAuth 2.0 authorization server, which can be configured to protect your Drupal

Affects drupal/simple_oauthSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.1.4 : patch drupal/simple_oauth soon.

Data as of 4 Nov 2026, 21:54 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 6.1.4, 6.0.10, 5.2.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade drupal/simple_oauth to 6.1.4, 6.0.10 or 5.2.6.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/simple_oauthAffected
  • <5.2.6
  • >=6.0.0 <6.0.10
  • >=6.1.0 <6.1.4
Fixed in
  • 5.2.6
  • 6.0.10
  • 6.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Simple OAuth module versions 5.2.6, 6.0.10, or 6.1.4 where this vulnerability is fixed. Restrict the Add consumer entities and Update own consumer entities permissions to trusted users only to reduce the risk of exploitation.

Description

The Simple OAuth module for Drupal introduces an OAuth 2.0 authorization server that can protect a Drupal instance with access tokens. A vulnerability exists because the module does not sufficiently restrict access to consumer configuration, allowing users with certain permissions to create or edit consumers that can obtain tokens with elevated privileges. This can lead to unauthorized access to the site as another user, including full administrative access. However, exploitation requires the attacker to already have roles with the Add consumer entities or Update own consumer entities permissions. Fixes are available in versions 5.2.6, 6.0.10, and 6.1.4.

References

Community reviews

Loading reviews…