CVE-2026-105782: Scrapy · Arbitrary Module Import via Referrer-Policy Header in RefererMiddleware
Affects scrapySource GCVE Database
Mentioned vulnerabilities
CVSS 7.5 High : upgrade to 2.14.2 soon.
Data as of 26 Oct 2026, 16:20 UTC
- Patch
- Available – fixed in 2.14.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HWhat to do
Upgrade scrapy to 2.14.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewscrapypkg:brew/scrapyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Scrapy to version 2.14.2 or later, where this vulnerability is patched. Applying this official fix fully mitigates the issue.
Description
Scrapy versions 2.9.0 up to but not including 2.14.2 have a vulnerability in the RefererMiddleware where the Referrer-Policy response header is improperly handled. If this header contains a value resembling a valid Python import path, Scrapy imports and executes the referenced object. This can be exploited by a malicious site to execute arbitrary code, potentially terminating the process and causing denial of service. A patch is available in Scrapy version 2.14.2.
References
- github.com/scrapy/scrapy/security/advisories/GHSA-cwxj-rr6w-m6w7 (opens in a new tab)
- github.com/scrapy/scrapy/commit/945b787a263586cb5803c01c6da57daad8997ae5 (opens in a new tab)
- github.com/scrapy/scrapy (opens in a new tab)
- github.com/scrapy/scrapy/releases/tag/2.14.2 (opens in a new tab)
- github.com/CVEProject/cvelistV5/tree/main/cves/2026/105xxx/CVE-2026-105782.json (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-105782 (opens in a new tab)
- github.com/scrapy/scrapy/commit/b6e5c58ae707a3d4bb491537b5519534050047e0 (opens in a new tab)