CVE-2026-92759: SecObserve versions before 1.59.1 contain an information disclosure vulnerability in the ApiConfigurationSerializer that fails to strip the
Affects SecObserveSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.59.1 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.59.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade secobserve/SecObserve to 1.59.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubsecobserve/SecObservepkg:github/secobserve/SecObserveOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in SecObserve version 1.59.1. Users should upgrade to version 1.59.1 or later to remediate this vulnerability. No vendor advisory or patch link was provided, so confirm patch availability from the vendor before upgrading.
Description
SecObserve versions prior to 1.59.1 have an information disclosure vulnerability in the ApiConfigurationSerializer component. This flaw causes the basic_auth_password field to be included in API configuration responses without being stripped. As a result, users with view-only access can retrieve decrypted basic-auth passwords of configured scanner or integration service accounts via standard REST endpoints.
References
- github.com/SecObserve/SecObserve/security/advisories/GHSA-r968-78vw-jj9m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-92759 (opens in a new tab)
- github.com/SecObserve/SecObserve/issues/4799 (opens in a new tab)
- github.com/SecObserve/SecObserve (opens in a new tab)
- github.com/SecObserve/SecObserve/blob/v1.54.0/backend/application/import_observations/api/serializers.py (opens in a new tab)
- github.com/SecObserve/SecObserve/releases/tag/v1.59.1 (opens in a new tab)
- vulncheck.com/advisories/secobserve-before-1.59.1-information-disclosure-via-api-configuration (opens in a new tab)