Skip to main content
CVE-2026-12185VulnerabilityPublished Updated

SUSE · Security update for bouncycastle

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-12185· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in SUSE package updates : patch SUSE bcprov soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.85, 2.73.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade BC-JAVA and bcprov to 1.85; BC-LTS-JAVA and bcprov-lts8on to 2.73.12.

Affected software

ProductAffectedFixed in
Legion of the Bouncy Castle Inc.BC-JAVAAffected
  • <1.85
Fixed in
  • 1.85
Legion of the Bouncy Castle Inc.BC-LTS-JAVAAffected
  • >=2.73.0 <2.73.12
Fixed in
  • 2.73.12
GitHubbcprovpkg:github/bcprovOther threatsAffected
  • <1.85
Fixed in
  • 1.85
GitHubbcprov-lts8onpkg:github/bcprov-lts8onOther threatsAffected
  • >=2.73.0 <2.73.12
Fixed in
  • 2.73.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to BouncyCastle version 1.85 or later to address these vulnerabilities. The update includes official fixes for all listed issues. No additional mitigation steps are indicated beyond applying this security update. Deprecated post-quantum cryptography algorithm packages should be replaced with the new `org.bouncycastle.crypto` namespace versions as recommended.

Description

A security update for BouncyCastle version 1.85 addresses multiple critical vulnerabilities affecting cryptographic operations, key management, and data integrity. These issues include bypasses, untrusted memory allocations, MAC forgery, improper validation, and denial-of-service risks. The update also repackages certain post-quantum cryptography algorithms and deprecates older versions. This update is critical to maintain the security and integrity of cryptographic functions in affected systems.

References

Community reviews

Loading reviews…