Skip to main content
CVE-2026-25547VulnerabilityPublished Updated

SUSE · Security update for cockpit-machines

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-25547· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade SUSE brace-expansion to 5.0.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade brace-expansion and @isaacs/brace-expansion to 5.0.1.

Affected software

ProductAffectedFixed in
isaacsbrace-expansionAffected
  • <5.0.1
Fixed in
  • 5.0.1
npm@isaacs/brace-expansionpkg:npm/@isaacs/brace-expansionOther threatsAffected
  • <5.0.1
Fixed in
  • 5.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update has been released for the affected cockpit-machines package versions on SUSE Linux Enterprise and SUSE Linux Micro 6.2 for the aarch64 architecture. Applying this update will remediate the vulnerabilities. Patch status is confirmed by the vendor advisory indicating the update fixes these issues. Users should apply the update to mitigate the risk.

Description

This security update for SUSE's cockpit-machines addresses two denial-of-service vulnerabilities: CVE-2026-25547, caused by unbounded brace range expansion in the brace-expansion library leading to excessive resource consumption and potential Node.js process crashes; and CVE-2026-26996, a Regular Expression Denial of Service (ReDoS) vulnerability in minimatch when processing certain glob patterns with repeated wildcards. The update fixes these issues in specific cockpit package versions for the aarch64 architecture.

References

Community reviews

Loading reviews…