Skip to main content
CVE-2025-30187VulnerabilityPublished Updated

SUSE · Security update for dnsdist

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-30187· Low 3.7

Not known to be exploited · CVSS 3.7 Low.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • SUSE
  • aarch64
  • dnsdist-1.9.11-160000.1.1.aarch64
  • ppc64le
  • dnsdist-1.9.11-160000.1.1.ppc64le
  • dnsdist-0:1.9.11-160000.1.1.aarch64
  • dnsdist-0:1.9.11-160000.1.1.ppc64le
Fixed in–

AI-suggested

Upgrade to dnsdist version 1.9.11 or later, which includes fixes and mitigations for these vulnerabilities. Since this is an official update from the vendor, applying this update is the recommended remediation.

Description

This security update for dnsdist addresses two vulnerabilities: CVE-2025-8671, which introduces mitigations for the HTTP/2 MadeYouReset attack, and CVE-2025-30187, a denial of service vulnerability via crafted DNS-over-HTTPS (DoH) exchanges. The update is included in dnsdist version 1.9.11. No specific affected versions are provided. The severity of the denial of service vulnerability is rated low. There is no CVSS score available for these issues.

References

Community reviews

Loading reviews…