Skip to main content
CVE-2026-1229VulnerabilityPublished Updated

SUSE · Security update for enc

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-1229· Low 2.9

Public exploit available · CVSS 2.9 Low : upgrade SUSE circl to 1.6.3 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.3
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:P/S:N/AU:Y/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade CIRCL and cloudflare/circl to 1.6.3.

Affected software

ProductAffectedFixed in
CloudflareCIRCLAffected
  • ≥ CIRCL up to version 1.6.2, < 1.6.3
Fixed in
  • 1.6.3
GitHubcloudflare/circlpkg:github/cloudflare/circlOther threatsAffected
  • <1.6.3
Fixed in
  • 1.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that addresses CVE-2026-1229 by fixing the incorrect value issue and updating dependencies. Users should apply the update to the 'enc' component, including the bump to circl 1.6.3 and dependency updates in versions 1.1.4 and 1.1.5. Patch status is confirmed by the vendor advisory.

Description

A security update for the 'enc' component addresses CVE-2026-1229 by fixing an incorrect value issue. The update includes a bump of the circl library to version 1.6.3 and updates dependencies in versions 1.1.4 and 1.1.5. The vulnerability is rated as high severity, but no CVSS score is provided.

References

Community reviews

Loading reviews…