Skip to main content
CVE-2025-56225VulnerabilityPublished Updated

SUSE fluidsynth · Security update for fluidsynth

Affects SUSE fluidsynthSource GCVE Database

0
Compare
Authoritative record:CVE-2025-56225· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the affected SUSE packages to 2.3.5-160000.3.1 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.5-160000.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the SUSE to 2.3.5-160000.3.1.

Affected software

ProductAffectedFixed in
SUSEsuse/fluidsynthpkg:rpm/suse/fluidsynthOther threatsAffected
  • <2.3.5-160000.3.1
Fixed in
  • 2.3.5-160000.3.1
SUSEsuse/fluidsynth-develpkg:rpm/suse/fluidsynth-develOther threatsAffected
  • <2.3.5-160000.3.1
Fixed in
  • 2.3.5-160000.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update has been released to fix this vulnerability. Users of fluidsynth should apply the update provided by their vendor or distribution to remediate this issue. Patch status is not explicitly confirmed in the provided data; therefore, check the vendor advisory for the latest remediation guidance.

Description

A security update for fluidsynth addresses a vulnerability identified as CVE-2025-56225, which involves a NULL pointer dereference triggered by loading an invalid MIDI file. This flaw could cause application crashes or denial of service. The update fixes this issue to improve stability and security.

References

Community reviews

Loading reviews…