Skip to main content
CVE-2026-32685VulnerabilityPublished Updated

SUSE · Security update for gleam

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited.

Data as of 31 Oct 2026, 20:20 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • SUSE
  • aarch64
  • gleam-1.17.0-bp160.1.1.aarch64
  • x86_64
  • gleam-1.17.0-bp160.1.1.x86_64
  • gleam-0:1.17.0-bp160.1.1.aarch64
  • gleam-0:1.17.0-bp160.1.1.x86_64
Fixed in–

AI-suggested

Users should upgrade to Gleam version 1.17.0 or later to apply the official fixes for these vulnerabilities. No additional mitigation steps are indicated beyond applying this update.

Description

This security update for the Gleam programming language addresses multiple vulnerabilities in version 1.17.0. The fixes include restricting custom documentation page paths and sources to prevent escaping the documentation output directory or project root, restricting publication tarball creation to exclude files outside the project root, and enforcing stricter deserialization rules to reject corrupted data in the build directory. These vulnerabilities are identified as CVE-2026-32685, CVE-2026-42795, and CVE-2026-43965. The update also includes various other bug fixes and feature improvements.

References

Community reviews

Loading reviews…