Skip to main content
CVE-2024-45508VulnerabilityPublished Updated

SUSE · Security update for htmldoc

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-45508· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade SUSE htmldoc to 1.9.19 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.19
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade michaelrsweet/htmldoc to 1.9.19.

Affected software

ProductAffectedFixed in
GitHubmichaelrsweet/htmldocpkg:github/michaelrsweet/htmldocOther threatsAffected
  • <1.9.19
Fixed in
  • 1.9.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that fixes the buffer overflow vulnerability and other issues. Users should upgrade to the fixed versions of htmldoc (at least version 1.9.23) to mitigate these vulnerabilities. No indication is given that additional mitigations are required beyond applying the update.

Description

A security update for htmldoc addresses multiple issues including a critical buffer overflow vulnerability (CVE-2024-46478) in the parse_pre function when handling tabs. The update also fixes various regressions and bugs across versions 1.9.19 through 1.9.23, improving stability and functionality. The buffer overflow flaw could potentially allow memory corruption. No CVSS score is provided, but the severity is marked critical.

References

Community reviews

Loading reviews…