Skip to main content
CVE-2025-8114VulnerabilityPublished Updated

SUSE libssh · Security update for libssh

Affects SUSE libsshSource GCVE Database

0
Compare
Authoritative record:CVE-2025-8114· Medium 4.7

Not known to be exploited · CVSS 4.7 Medium : upgrade the Suse suse/libssh package to 0.11.4 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.11.4
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the Suse suse/libssh package to 0.11.4.

Affected software

ProductAffectedFixed in
Susesuse/libsshpkg:deb/suse/libsshOther threatsAffected
  • <0.11.4
Fixed in
  • 0.11.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade libssh to version 0.11.4 or later, which contains fixes for all identified vulnerabilities. No additional mitigation steps are indicated beyond applying this security update.

Description

Multiple security vulnerabilities have been identified in libssh affecting components such as SCP protocol handling, configuration file parsing, hexadecimal input processing, pattern matching, SFTP longname parsing, and key exchange handling. These include path traversal, denial of service, buffer underflow, out-of-bounds read, null pointer dereference, and memory leak issues. The vulnerabilities are addressed in libssh version 0.11.4.

References

Community reviews

Loading reviews…