Skip to main content
CVE-2026-88806VulnerabilityPublished Updated

SUSE · Security update for libX11

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-88806· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade SUSE libx11 to 1.8.14 soon.

Data as of 4 Nov 2026, 02:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.14
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade libX11 and x.org/libx11 to 1.8.14.

Affected software

ProductAffectedFixed in
x.orglibX11Affected
  • <1.8.14
Fixed in
  • 1.8.14
X.orgx.org/libx11pkg:deb/x.org/libx11Other threatsAffected
  • <1.8.14
Fixed in
  • 1.8.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for libX11 has been released by the SUSE Product Security Team to fix this vulnerability. Users should apply the official update provided by their vendor or distribution to remediate this issue. Patch status is not explicitly confirmed in the input; therefore, verify with the vendor advisory for current remediation guidance.

Description

A security update for libX11 addresses a heap-based buffer overflow vulnerability identified as CVE-2026-88806 in the XkbGetMap Reply functionality. This flaw could potentially lead to memory corruption issues. The vulnerability is rated as high severity.

References

Community reviews

Loading reviews…