Skip to main content
CVE-2026-109089VulnerabilityPublished Updated

SUSE · Security update for libXi

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-109089· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade SUSE to 1.8.4 soon.

Data as of 27 Oct 2026, 15:57 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.8.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade libXi to 1.8.4.

Affected software

ProductAffectedFixed in
X.OrglibXiAffected
  • <1.8.4
Fixed in
  • 1.8.4

AI-suggested

A security update for libXi has been released by the SUSE Product Security Team that fixes these vulnerabilities. Users should apply the official update to remediate these issues. No additional mitigation steps are indicated or required beyond applying the patch.

Description

Multiple out-of-bounds read vulnerabilities and heap buffer overflows have been identified and fixed in the libXi library used by SUSE. These issues affect various functions including XQueryDeviceState, XI2 class parsing, XIQueryDevice reply parsing, XListInputDevices, and XGetDeviceControl. The vulnerabilities could lead to memory corruption or crashes.

References

Community reviews

Loading reviews…