Skip to main content
CVE-2026-41082VulnerabilityPublished Updated

SUSE · Security update for opam

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-41082· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade SUSE opam to 2.5.1 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade opam and ocaml/opam to 2.5.1.

Affected software

ProductAffectedFixed in
OCamlopamAffected
  • <2.5.1
Fixed in
  • 2.5.1
GitHubocaml/opampkg:github/ocaml/opamOther threatsAffected
  • <2.5.1
Fixed in
  • 2.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update opam to version 2.5.2 or later to apply the official fixes for CVE-2026-41082 and CVE-2026-57825. The vendor has released these updates as the official remediation. No additional mitigation steps are indicated.

Description

This security update for opam addresses multiple vulnerabilities by updating the software to versions 2.5.0, 2.5.1, and 2.5.2. Notably, CVE-2026-41082 and CVE-2026-57825 are fixed in these updates. The update is provided by the SUSE Product Security Team and is classified as high severity. No CVSS score is available for these vulnerabilities.

References

Community reviews

Loading reviews…