Skip to main content
CVE-2026-10294VulnerabilityPublished Updated

SUSE PackageKit · Security update for PackageKit

Affects SUSE PackageKitSource GCVE Database

0
Compare
Authoritative record:CVE-2026-10294· Medium 5.3

Public exploit available · CVSS 5.3 Medium : upgrade the affected SUSE packages to 1.2.8-160000.5.1.aarch64 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.8-160000.5.1.aarch64
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the SUSE to 1.2.8-160000.5.1.aarch64.

Affected software

ProductAffectedFixed in
SUSEsuse/PackageKitpkg:rpm/suse/PackageKitOther threatsAffected
  • <1.2.8-160000.5.1.aarch64
Fixed in
  • 1.2.8-160000.5.1.aarch64
SUSEsuse/PackageKit-backend-dnfpkg:rpm/suse/PackageKit-backend-dnfOther threatsAffected
  • <1.2.8-160000.5.1.aarch64
Fixed in
  • 1.2.8-160000.5.1.aarch64
SUSEsuse/PackageKit-backend-zypppkg:rpm/suse/PackageKit-backend-zyppOther threatsAffected
  • <1.2.8-160000.5.1.aarch64
Fixed in
  • 1.2.8-160000.5.1.aarch64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for PackageKit has been released by the SUSE Product Security Team to fix this vulnerability. Users should apply the update to remediate the issue. No additional mitigation steps are specified.

Description

A security update for PackageKit addresses CVE-2026-10294, which involves improper authorization due to manipulation of the argument frontend-socket. This vulnerability could allow unauthorized actions within PackageKit. The update also fixes a non-security issue related to KDE Discover ignoring package locks.

References

Community reviews

Loading reviews…