Skip to main content
CVE-2026-15689VulnerabilityPublished Updated

SUSE · Security update for perl-Dancer2-Plugin-Auth-Extensible

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-15689· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in SUSE package updates : patch SUSE Dancer2-Plugin-Auth-Extensible as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.713.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
ABEVERLEYDancer2::Plugin::Auth::ExtensibleAffected
  • <=0.713
Fixed in–
GitHubDancer2-Plugin-Auth-Extensiblepkg:github/Dancer2-Plugin-Auth-ExtensibleOther threatsAffected
  • <=0.713
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade perl-Dancer2-Plugin-Auth-Extensible to version 0.713.0 or later, which introduces the uri_base parameter to prevent malicious link generation in emails. Ensure the application enforces a fixed hostname or explicitly sets the uri_base parameter when generating email links.

Description

A security update for perl-Dancer2-Plugin-Auth-Extensible addresses a vulnerability (CVE-2026-15689) related to generating links in emails with dynamic hosts. The issue allowed attackers to craft password reset and welcome emails containing links to malicious hosts if the application did not enforce a fixed hostname. The update introduces a uri_base parameter to mitigate this risk and fixes related test failures.

References

Community reviews

Loading reviews…