Skip to main content
CVE-2026-10879VulnerabilityPublished Updated

SUSE · Security update for perl-DBI

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-10879· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade SUSE DBI to 1.648 as a priority.

Data as of 1 Nov 2026, 11:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.648
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade DBI to 1.648.

Affected software

ProductAffectedFixed in
HMBRANDDBIAffected
  • <1.648
Fixed in
  • 1.648
GitHubDBIpkg:github/DBIOther threatsAffected
  • <1.648
Fixed in
  • 1.648

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that fixes these vulnerabilities in perl-DBI version 1.648 and later. Users should upgrade to version 1.648 or newer to remediate these issues. No information on alternative mitigations is provided, so applying the official update is the recommended action.

Description

This security update for perl-DBI addresses two vulnerabilities affecting versions prior to 1.648. The first vulnerability (CVE-2026-9698) involves saving errors in a limited-sized buffer, and the second (CVE-2026-10879) involves a heap overflow triggered by SQL statements with more than 9 binders. Both vulnerabilities can cause memory corruption or instability in applications using affected versions of perl-DBI.

References

Community reviews

Loading reviews…