Skip to main content
CVE-2026-8450VulnerabilityPublished Updated

SUSE · Security update for perl-HTTP-Daemon

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-8450· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade SUSE HTTP-Daemon to 6.17 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade HTTP::Daemon and HTTP-Daemon to 6.17.

Affected software

ProductAffectedFixed in
OALDERSHTTP::DaemonAffected
  • <6.17
Fixed in
  • 6.17
GitHubHTTP-Daemonpkg:github/HTTP-DaemonOther threatsAffected
  • <6.17
Fixed in
  • 6.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available that fixes this vulnerability in perl-HTTP-Daemon version 6.17 and later. Users should upgrade to version 6.17 or later to remediate this issue. No additional mitigation guidance is provided, and no indication that the issue is already mitigated without patching.

Description

A security update for perl-HTTP-Daemon addresses a vulnerability identified as CVE-2026-8450. This vulnerability allows OS command injection via the send_file() function in versions before 6.17. The issue is rated as high severity.

References

Community reviews

Loading reviews…