Skip to main content
CVE-2025-11683VulnerabilityPublished Updated

SUSE · Security update for perl-YAML-Syck

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-11683· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in SUSE package updates : update SUSE when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.37
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • SUSE
  • aarch64
  • perl-YAML-Syck-1.450.0-bp160.1.1.aarch64
  • ppc64le
  • perl-YAML-Syck-1.450.0-bp160.1.1.ppc64le
  • perl-YAML-Syck-0:1.450.0-bp160.1.1.aarch64
  • perl-YAML-Syck-0:1.450.0-bp160.1.1.ppc64le
Fixed in–

AI-suggested

A security update is available that fixes the critical heap buffer overflow and other bugs. Users should upgrade perl-YAML-Syck to version 1.37 or later, preferably to the latest version 1.45.0, to ensure all fixes are applied. No additional mitigation steps are indicated beyond applying the official update.

Description

This security update for perl-YAML-Syck addresses multiple bugs and vulnerabilities, including a critical heap buffer overflow (CVE-2026-4177) in the YAML emitter. The update fixes memory leaks, parsing errors, and crashes on Windows, improving stability and security. The fixes are included in versions 1.37 and later, with the critical heap buffer overflow resolved in version 1.37.

References

Community reviews

Loading reviews…