Skip to main content
CVE-2026-6472VulnerabilityPublished

SUSE · Security update for postgresql14

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-6472· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium · fixed in SUSE package updates : update SUSE postgresql when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <14.23
  • <15.18
  • <16.14
  • <17.10
  • <18.4
Fixed in
  • 14.23
  • 15.18
  • 16.14
  • 17.10
  • 18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

This update for postgresql14 fixes the following issues Update to version 14.23. Security issues: - CVE-2026-6472: ensure the user has CREATE privilege on the schema specified (bsc#1265172). - CVE-2026-6473: integer overflows in memory-allocation calculations (bsc#1265173). - CVE-2026-6474: Guard against malicious time zone names (bsc#1265174). - CVE-2026-6475: Prevent path traversal in pg_basebackup and pg_rewind (bsc#1265175). - CVE-2026-6477: Mark PQfn() as unsafe, and avoid using it within libpq (bsc#1265177). - CVE-2026-6478: Use timing-safe string comparisons in authentication code (bsc#1265178). - CVE-2026-6479: Prevent unbounded recursion while processing startup packets (bsc#1265179). - CVE-2026-6637: Prevent SQL injection and buffer overruns in contrib/spi (bsc#1265181). Non security issue: - Get rid of update-alternatives for openSUSE/SLE 16.0 and newer to support immutable systems and transactional updates (jsc#PED-14823). - /usr/bin/pg_config is missing after migrating away from update-alternatives (bsc#1263804).

References

Community reviews

Loading reviews…