Skip to main content
VulnerabilityPublished

CVE-2026-6472: PostgreSQL · Missing Authorization

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium · fixed in 18.4 : update PostgreSQL when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
PostgreSQLAffected
  • >=15 <15.18
Fixed in
  • 15.18
PostgreSQLAffected
  • <14.23
Fixed in
  • 14.23
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <14.23
  • <15.18
  • <16.14
  • <17.10
  • <18.4
Fixed in
  • 14.23
  • 15.18
  • 16.14
  • 17.10
  • 18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict the ability to create types to trusted users only and review database permissions to limit exposure.

Description

CVE-2026-6472 is a medium severity vulnerability in PostgreSQL affecting versions prior to 18.4, 17.10, 16.14, 15.18, and 14.23. It involves missing authorization checks in the CREATE TYPE command, allowing an attacker who can create objects to hijack queries that rely on search_path to locate user-defined or extension-defined types. This can cause victims to execute arbitrary SQL functions chosen by the attacker.

References

Community reviews

Loading reviews…