Skip to main content
VulnerabilityPublished

CVE-2026-6638: PostgreSQL · SQL Injection

Affects PostgreSQLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.7 Low · fixed in 18.4 : update PostgreSQL when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.4, 17.10, 16.14
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PostgreSQL to 18.4, 17.10 or 16.14.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • >=18 <18.4
Fixed in
  • 18.4
PostgreSQLAffected
  • >=17 <17.10
Fixed in
  • 17.10
PostgreSQLAffected
  • >=16 <16.14
Fixed in
  • 16.14
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • =16
  • =17
  • =18
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution with subscription table creators and the use of REFRESH PUBLICATION commands.

Description

CVE-2026-6638 is a low-severity SQL injection vulnerability in PostgreSQL affecting logical replication commands. Specifically, the ALTER SUBSCRIPTION ... REFRESH PUBLICATION command allows a subscriber table creator to execute arbitrary SQL using the publication-side credentials. This vulnerability impacts PostgreSQL major versions 16, 17, and 18, but only in minor versions before 16.14, 17.10, and 18.4. Versions prior to 16 are not affected. The attack executes at the next REFRESH PUBLICATION operation.

References

Community reviews

Loading reviews…