Skip to main content
VulnerabilityPublished

CVE-2026-44374: @backstage plugin-catalog-backend-module-unprocessed · Incorrect Authorization

Affects @backstage plugin-catalog-backend-module-unprocessedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 0.6.11 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.11, 0.2.30, 0.0.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade plugin-catalog-backend-module-unprocessed and @backstage/plugin-catalog-backend-module-unprocessed to 0.6.11; plugin-catalog-unprocessed-entities to 0.2.30; plugin-catalog-unprocessed-entities-common to 0.0.15.

Affected software

ProductAffectedFixed in
@backstageplugin-catalog-backend-module-unprocessedAffected
  • <0.6.11
Fixed in
  • 0.6.11
@backstageplugin-catalog-unprocessed-entitiesAffected
  • <0.2.30
Fixed in
  • 0.2.30
@backstageplugin-catalog-unprocessed-entities-commonAffected
  • <0.0.15
Fixed in
  • 0.0.15
npm@backstage/plugin-catalog-backend-module-unprocessedpkg:npm/@backstage/plugin-catalog-backend-module-unprocessedOther threatsAffected
  • <0.6.11
Fixed in
  • 0.6.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Backstage modules to the fixed versions: @backstage/plugin-catalog-backend-module-unprocessed version 0.6.11 or later, @backstage/plugin-catalog-unprocessed-entities-common version 0.0.15 or later, and @backstage/plugin-catalog-unprocessed-entities version 0.2.30 or later. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor advisory information.

Description

CVE-2026-44374 is an information disclosure vulnerability in Backstage's @backstage/plugin-catalog-backend-module-unprocessed prior to version 0.6.11. The issue arises because the unprocessed entities read endpoints do not enforce permission authorization checks, allowing any authenticated user to access unprocessed entity records regardless of ownership. This vulnerability has a medium severity rating with a CVSS score of 4.3. It is addressed by updating to version 0.6.11 or later of the affected module and related packages.

References

Community reviews

Loading reviews…