CVE-2026-44482: richardhbtz soundcloud-rpc · Improper Input Validation
Affects richardhbtz soundcloud-rpcSource CVE Database V5
Not known to be exploited · CVSS 9.6 Critical : upgrade to 0.1.8 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.1.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade richardhbtz soundcloud-rpc to 0.1.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| richardhbtzsoundcloud-rpc | Affected
| Fixed in
|
npmsoundcloud-rpcpkg:npm/soundcloud-rpcOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade soundcloud-rpc to version 0.1.8 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Users should avoid using vulnerable versions to prevent local command execution risks.
Description
CVE-2026-44482 is a critical vulnerability in soundcloud-rpc versions prior to 0.1.8. The application improperly validates input from SoundCloud track metadata, allowing an attacker to embed HTML payloads in track titles. This payload executes locally within the Electron app, potentially leading to local command execution due to the rendering of untrusted HTML in privileged views with Node.js integration enabled. The vulnerability arises from trusting and forwarding track metadata through IPC without sanitization. This issue is fixed in version 0.1.8.