Skip to main content
CVE-2026-31899VulnerabilityPublished Updated

SUSE · Security update for python-CairoSVG

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-31899· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade SUSE cairosvg to 2.9.0 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade CairoSVG and cairosvg to 2.9.0.

Affected software

ProductAffectedFixed in
KozeaCairoSVGAffected
  • <2.9.0
Fixed in
  • 2.9.0
PyPIcairosvgpkg:pypi/cairosvgOther threatsAffected
  • <2.9.0
Fixed in
  • 2.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for python-CairoSVG has been released by the SUSE Product Security Team that fixes this denial of service vulnerability. Users should apply the update to remediate the issue. Patch status is confirmed by the vendor advisory indicating the issue is fixed.

Description

A security update for python-CairoSVG addresses CVE-2026-31899, which involves a denial of service vulnerability caused by recursive <use> element amplification. This flaw could allow an attacker to trigger resource exhaustion by exploiting recursive SVG elements. The issue has been fixed in the update provided by the SUSE Product Security Team.

References

Community reviews

Loading reviews…