Skip to main content
CVE-2026-61548VulnerabilityPublished Updated

SUSE rsyslog · Security update for rsyslog

Affects SUSE rsyslogSource GCVE Database

0
Compare

Not known to be exploited · fixed in Ubuntu package updates : patch the Ubuntu rsyslog package soon.

Data as of 31 Oct 2026, 20:20 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.2112.0-2ubuntu2.4, 8.2312.0-3ubuntu9.3, 8.2512.0-1ubuntu4.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the Ubuntu rsyslog to 8.2112.0-2ubuntu2.4 (package) or 8.2312.0-3ubuntu9.3 (package) or 8.2512.0-1ubuntu4.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=resoluteOther threatsAffected
  • <8.2512.0-1ubuntu4.1
Fixed in
  • 8.2512.0-1ubuntu4.1
Ubuntu 24.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=nobleOther threatsAffected
  • <8.2312.0-3ubuntu9.3
Fixed in
  • 8.2312.0-3ubuntu9.3
Ubuntu 22.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=jammyOther threatsAffected
  • <8.2112.0-2ubuntu2.4
Fixed in
  • 8.2112.0-2ubuntu2.4
Ubuntu Pro 20.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=esm-infra/focalOther threatsAffected
  • 8.1901.0-1ubuntu4 – 8.2001.0-1ubuntu1.3+esm1
5 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 8.16.0-1ubuntu9 – 8.32.0-1ubuntu4.2+esm1
6 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 8.12.0-1ubuntu2 – 8.16.0-1ubuntu3.1+esm3
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in rsyslog version 8.2606.0. Users should update to this version or later to remediate the vulnerability. Systems not using the mmpstrucdata plugin or with message size limits below the threshold are not affected. Standard system updates on supported Ubuntu releases will apply the necessary patches as detailed in the Ubuntu Security Notice USN-8598-1.

Description

Rsyslog versions from 7.5.4 up to but not including 8.2606.0 contain a vulnerability in the optional mmpstrucdata plugin. The vulnerability arises from the parseSD_PARAM function using a fixed-size stack buffer without proper bounds checking, allowing a remote unauthenticated attacker to send an oversized RFC5424 structured-data parameter that causes a stack overwrite. This can lead to a crash and interruption of log collection. Systems not using the plugin or with message size limits below the threshold are not affected. The issue is fixed in version 8.2606.0.

References

Community reviews

Loading reviews…