Skip to main content
CVE-2026-41316VulnerabilityPublished Updated

SUSE · security update for ruby

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-41316· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in SUSE package updates : patch SUSE erb soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.1% chance of exploitation in 30 days – higher than 66% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.4, 6.0.1.1, 4.0.3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade erb to 6.0.4, 6.0.1.1 or 4.0.3.1; erb to 4.0.3.1.

Affected software

ProductAffectedFixed in
rubyerbAffected
  • <4.0.3.1
  • >=5.0.0 <6.0.1.1
  • >=6.0.2 <6.0.4
  • =4.0.4
Fixed in
  • 6.0.4
  • 6.0.1.1
  • 4.0.3.1
RubyGemserbpkg:gem/erbOther threatsAffected
  • <4.0.3.1
  • =4.0.4
Fixed in
  • 4.0.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update has been issued by the SUSE Product Security Team. Users should apply the update as recommended by SUSE and consult the original Red Hat advisory RHSA-2026:37238 for detailed remediation instructions. Patch status is not explicitly confirmed in the provided data; therefore, users should verify the availability and applicability of the update through official SUSE channels.

Description

This is a security update for Ruby provided by the SUSE Product Security Team, functionally equivalent to Red Hat's advisory RHSA-2026:37238. The update addresses a high-severity vulnerability identified as CVE-2026-41316.

References

Community reviews

Loading reviews…