Skip to main content
CVE-2026-31812VulnerabilityPublished Updated

SUSE · Security update for rust1.94

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-31812· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade SUSE quinn to 0.11.14 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.11.14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade quinn and quinn-rs/quinn to 0.11.14.

Affected software

ProductAffectedFixed in
quinn-rsquinnAffected
  • <0.11.14
Fixed in
  • 0.11.14
crates.ioquinn-rs/quinnpkg:cargo/quinn-rs/quinnOther threatsAffected
  • <0.11.14
Fixed in
  • 0.11.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the rust1.94.1 update as provided by the vendor to address CVE-2026-31812 and related issues. The update includes an official fix, so upgrading to this version or later is recommended.

Description

A security update for rust1.94 addresses multiple issues including a fix for CVE-2026-31812, which involves avoiding unwrapping varint decoding during parameters parsing. The update also includes a change to not force gcc-15 on SLE-16 and higher. The vulnerability is rated medium severity and no CVSS score is provided.

References

Community reviews

Loading reviews…