Skip to main content
CVE-2026-116885VulnerabilityPublished

Semantic MediaWiki from 3.1.0 before 7.3.1 contains a reflected cross-site scripting vulnerability in the

Source GCVE Database

0
Authoritative record:CVE-2026-116885· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 7.3.1 when convenient.

Data as of 27 Oct 2026, 13:29 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.3.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SemanticMediaWiki and semanticmediawiki/SemanticMediaWiki to 7.3.1.

Affected software

ProductAffectedFixed in
SemanticMediaWikiSemanticMediaWikiAffected
  • >=3.1.0 <7.3.1
Fixed in
  • 7.3.1
GitHubsemanticmediawiki/SemanticMediaWikipkg:github/semanticmediawiki/SemanticMediaWikiOther threatsAffected
  • >=3.1.0 <7.3.1
Fixed in
  • 7.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version is available starting from Semantic MediaWiki 7.3.1. Users should upgrade to version 7.3.1 or later to remediate this vulnerability. No vendor advisory or patch link was provided in the input, so confirm patch availability from official Semantic MediaWiki sources before upgrading. Until patched, administrators should avoid clicking untrusted or unexpected Special:SMWAdmin ID lookup links.

Description

Semantic MediaWiki versions from 3.1.0 up to but not including 7.3.1 contain a reflected cross-site scripting (XSS) vulnerability in the Special:SMWAdmin ID lookup feature. This vulnerability allows unauthenticated attackers to inject malicious markup via the unescaped 'id' parameter. By tricking an administrator into clicking a crafted link, attackers can bypass the auto-satisfied edit-token check and execute scripts within the administrator's session, potentially performing privileged actions.

References

Community reviews

Loading reviews…