Skip to main content
VulnerabilityPublished

CVE-2026-82840: Apache Wicket · Session Fixation

Affects wicket-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-82840· High 7.2

Not known to be exploited · CVSS 7.2 High · fixed in 8.20.0 : patch wicket-core soon.

Data as of 2 Nov 2026, 01:00 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.07.2
Patch
Available – fixed in 8.20.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.wicket/wicket-corepkg:maven/org.apache.wicket/wicket-coreOther threatsAffected
  • >=8.18.0 <=8.19.0
  • >=9.23.0 <=9.24.0
  • >=10.9.0 <=10.11.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Wicket to versions 8.20.0, 9.25.0, or 10.12.0 where this issue is fixed. As a workaround, applications can call Session#changeSessionId() explicitly after every successful authentication to ensure session ID renewal. Applications that already perform session ID renewal after authentication are not affected and require no additional action.

Description

Apache Wicket versions 8.18.0 through 8.19.0, 9.23.0 through 9.24.0, and 10.9.0 through 10.11.0 are affected by a session fixation vulnerability. The issue arises because the session ID is renewed only on the first sign-in, not on subsequent authentications within the same session. This allows an attacker who can fix a session ID in a victim's browser and has a signed-in session to bypass session ID renewal on re-authentication, potentially enabling session fixation attacks. Upgrading to versions 8.20.0, 9.25.0, or 10.12.0 mitigates this vulnerability.

References

Community reviews

Loading reviews…