CVE-2026-110857: Snakemake · GitPython command wrappers omit unsafe protocol and option checks
Affects snakemakeSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.7 High : upgrade to 9.27.0_1 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.27.0_1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade snakemake to 9.27.0_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewsnakemakepkg:brew/snakemakeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Snakemake version 9.27.0_1 that adds the missing unsafe protocol and option checks to the affected methods. Users should upgrade to this version or later to remediate the vulnerability. Until patched, ensure that git configurations disallow unsafe transport protocols like 'ext' (default in git >= 2.38.1) to reduce exposure. No other specific mitigations are indicated by the vendor advisory.
Description
CVE-2026-110857 is a vulnerability in Snakemake's use of GitPython where three Git command wrapper methods omit critical checks for unsafe protocols and options. This omission allows potential remote code execution (RCE) when using the ls_remote method with certain git transport protocols, specifically the 'ext' transport if permitted by the victim's git configuration. The merge_base and IndexFile.move methods also forward caller-controlled arguments without proper sanitization, creating latent injection surfaces. The vulnerability affects Snakemake versions from 5.5.3 up to but not including 9.27.0_1. A fix is available in version 9.27.0_1.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-w8jc-g24h-crhw (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2251 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/9ad28cc4c7176d22cd6181d69805058a719dd03b (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.2.0 (opens in a new tab)