Skip to main content
CVE-2026-110858VulnerabilityPublished

Snakemake: GitPython Remote.pull() refspec bypasses the --upload-pack unsafe-option guard, enabling arbitrary command

Affects snakemakeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110858· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 9.27.0_1 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.27.0_1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade snakemake to 9.27.0_1.

Affected software

ProductAffectedFixed in
Homebrewsnakemakepkg:brew/snakemakeOther threatsAffected
  • >=7.20.0 <9.27.0_1
Fixed in
  • 9.27.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Snakemake version 9.27.0_1 that fixes this vulnerability by properly validating the positional refspec argument against unsafe options. Users should upgrade to version 9.27.0_1 or later. No additional mitigation is required once patched.

Description

GitPython's Remote.pull() method improperly handles the positional refspec argument, allowing an attacker to inject a malicious --upload-pack option that bypasses the unsafe-option guard. This leads to arbitrary command execution with the privileges of the calling process when using local-path or SSH transports. The vulnerability affects Snakemake versions from 7.20.0 up to but not including 9.27.0_1. A fix is available in version 9.27.0_1.

References

Community reviews

Loading reviews…