Skip to main content
VulnerabilityPublished Updated

CVE-2026-115910: Social auth core · Python Social Auth is a social authentication and registration mechanism

Affects social-auth-coreSource GCVE Database

0
Authoritative record:CVE-2026-115910· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium · fixed in 6.2.0 : update social-auth-core when convenient.

Data as of 28 Oct 2026, 22:58 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.2.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10social-auth-corepkg:deb/ubuntu/social-auth-core?arch=source&distro=stonkingOther threatsAffected
  • =4.8.3-1
  • =5.0.2-1
Fixed in–
Ubuntu 26.04 LTSsocial-auth-corepkg:deb/ubuntu/social-auth-core?arch=source&distro=resoluteOther threatsAffected
  • =4.6.1-1
  • =4.8.1-1
  • =4.8.3-1
Fixed in–
Ubuntu 24.04 LTSsocial-auth-corepkg:deb/ubuntu/social-auth-core?arch=source&distro=nobleOther threatsAffected
  • =4.4.2-2
  • =4.5.3-1
Fixed in–
Ubuntu 22.04 LTSsocial-auth-corepkg:deb/ubuntu/social-auth-core?arch=source&distro=jammyOther threatsAffected
  • =3.1.0-1.1
  • =4.1.0-1
  • =4.2.0-1
Fixed in–
Ubuntu 20.04 LTSsocial-auth-corepkg:deb/ubuntu/social-auth-core?arch=source&distro=focalOther threatsAffected
  • =3.1.0-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Python Social Auth to version 6.2.0 or later, where this nonce handling issue is fixed. Ensure that DEFAULT_USE_PKCE is enabled in the OpenIdConnectAuth configuration to enforce PKCE, which mitigates this attack vector. No other specific mitigations are indicated.

Description

Python Social Auth versions prior to 6.2.0 contain a vulnerability in the OpenIdConnectAuth backend where the OpenID Connect nonce is stored globally rather than being bound to the browser session and OAuth state. This allows an attacker who obtains a victim's unused authorization code to reuse it by initiating a separate login with a valid state, bypassing nonce validation and potentially logging in as the victim if PKCE is disabled. The issue is fixed in version 6.2.0.

References

Community reviews

Loading reviews…