Skip to main content
VulnerabilityPublished Updated

CVE-2026-86000: Soup Sieve · Polynomial-time ReDoS (O(n²)) in the `IDENTIFIER` / `VALUE` selector sub-patterns

Affects lexiconSource GCVE Database

0
Compare
Authoritative record:CVE-2026-86000· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.25.2_3 when convenient.

Data as of 30 Oct 2026, 07:31 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.25.2_3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade lexicon to 3.25.2_3.

Affected software

ProductAffectedFixed in
Homebrewlexiconpkg:brew/lexiconOther threatsAffected
  • >=3.11.2 <3.25.2_3
Fixed in
  • 3.25.2_3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in soupsieve version 3.25.2_3 that fixes this ReDoS vulnerability. Users should upgrade to this version or later. Applications that do not accept user-controlled CSS selectors are not affected. No other mitigation is required if the patch is applied.

Description

A Regular Expression Denial of Service (ReDoS) vulnerability exists in soupsieve's CSS selector parsing, specifically in the IDENTIFIER and VALUE sub-patterns. The flaw causes quadratic backtracking when parsing certain crafted selectors that fail to match, resulting in excessive CPU consumption. This can be triggered by user-controlled CSS selectors passed to soupsieve or BeautifulSoup's select methods. The vulnerability affects soupsieve versions from 3.11.2 up to but not including 3.25.2_3. A fix is available in version 3.25.2_3.

References

Community reviews

Loading reviews…