CVE-2026-49477: Soup Sieve · Regular Expression Denial of Service (ReDoS) via Selector Parser
Affects lexiconSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 3.25.2_2 soon.
Data as of 30 Oct 2026, 07:31 UTC
- Patch
- Available – fixed in 3.25.2_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade lexicon to 3.25.2_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewlexiconpkg:brew/lexiconOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading soupsieve to version 3.25.2_2 or later. Applications using soupsieve or Beautiful Soup's select methods with untrusted input should update to this fixed version to prevent ReDoS attacks. No other mitigations are specified or required.
Description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in soupsieve's CSS selector parser due to a regex pattern that suffers catastrophic backtracking when processing attribute selectors with unterminated quoted values. This flaw allows an attacker to cause CPU exhaustion by passing crafted CSS selectors to soupsieve.compile() or Beautiful Soup's select methods. The attack requires only about 300 bytes of input to cause a multi-second hang, with exponential backtracking time as input length increases. The vulnerability affects soupsieve versions from 3.11.2 up to but not including 3.25.2_2. A fix is available in version 3.25.2_2.