CVE-2026-49477: Soup Sieve · Regular Expression Denial of Service (ReDoS) via Selector Parser
Affects manimSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.20.1_1 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.20.1_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade manim to 0.20.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmanimpkg:brew/manimOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in soupsieve version 0.20.1_1. Users should upgrade to this version or later to remediate the issue. Until patched, avoid passing untrusted or user-supplied CSS selectors to soupsieve.compile() or Beautiful Soup's select methods. Implementing input validation or limiting selector input size may reduce risk but is not a complete mitigation. Patch status is confirmed by the vendor's fixed version information.
Description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in soupsieve's CSS selector parser due to a regex pattern that suffers from catastrophic backtracking when processing attribute selectors with unterminated quoted values. This flaw allows an attacker to cause CPU exhaustion by supplying a crafted CSS selector string, leading to thread blocking and significant processing delays. The vulnerability affects soupsieve versions from 0.19.0 up to but not including 0.20.1_1 and has been assigned CVE-2026-49477. A fix is available in version 0.20.1_1.