SPIP before 4.4.29 contains a SQL injection vulnerability that allows authenticated attackers with back-office access
Affects spipSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 4.4.29 : patch spip soon.
Data as of 6 Nov 2026, 05:03 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 4.4.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10spippkg:deb/ubuntu/spip?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSspippkg:deb/ubuntu/spip?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSspippkg:deb/ubuntu/spip?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSspippkg:deb/ubuntu/spip?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSspippkg:deb/ubuntu/spip?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSspippkg:deb/ubuntu/spip?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of SPIP is available starting from version 4.4.29. Users should upgrade to version 4.4.29 or later to remediate this vulnerability. No other mitigation or workaround is indicated in the available data.
Description
SPIP versions before 4.4.29 contain a SQL injection vulnerability that allows authenticated users with back-office access to inject arbitrary SQL via a mismatch in the 'where' parameter between POST and GET requests on the /ecrire/?exec=articles endpoint. This flaw bypasses the usual sanitization and can lead to unauthorized extraction of database contents, including protected articles and bcrypt password hashes.