CVE-2026-115878: Stanza · RCE via pickle deserialization in the lemmatizer
Affects stanzaSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.8 High : upgrade to 1.15.0 soon.
Data as of 3 Nov 2026, 21:43 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.8 |
|---|
- Patch
- Available – fixed in 1.15.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade stanza to 1.15.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIstanza | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Stanza version 1.15.0 that replaces the unsafe pickle deserialization with a restricted unpickler allowing only safe data types. Users should upgrade to version 1.15.0 or later. Until upgraded, users must avoid loading lemma model checkpoint files from untrusted or attacker-controlled sources. No other mitigation is indicated by the vendor advisory.
Description
Stanza versions 1.14.0 up to but not including 1.15.0 contain a remote code execution vulnerability via unsafe pickle deserialization in the lemmatizer component. The lemmatizer checkpoint stores a compressed pickle of a pos_dict, which is deserialized without restriction, allowing attacker-supplied model files to execute arbitrary code during pipeline construction. This occurs when loading a lemma model checkpoint from an untrusted source. The vulnerability is fixed in version 1.15.0 by using a restricted unpickler that only allows safe data types.
References
- github.com/stanfordnlp/stanza/security/advisories/GHSA-gh9r-c94j-cmp5 (opens in a new tab)
- github.com/stanfordnlp/stanza/pull/1649 (opens in a new tab)
- github.com/stanfordnlp/stanza/commit/b21e1c9b47b4fccff21d3b0a6c0687a19410c2f0 (opens in a new tab)
- github.com/stanfordnlp/stanza (opens in a new tab)
- github.com/stanfordnlp/stanza/releases/tag/v1.15.0 (opens in a new tab)