Skip to main content
CVE-2026-25075VulnerabilityPublished Updated

strongSwan versions 4.5.0 prior to 6.0.5 contain an integer underflow vulnerability in the EAP-TTLS AVP parser that

Source GCVE Database

0

Not known to be exploited · CVSS 7.5 High · fixed in 6.0.5 : patch affected systems soon.

Data as of 27 Oct 2026, 01:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

A fix is available in strongSwan version 6.0.5. Users should upgrade to version 6.0.5 or later to remediate this vulnerability.

Description

strongSwan versions from 4.5.0 up to but not including 6.0.5 contain an integer underflow vulnerability in the EAP-TTLS AVP parser. This flaw allows unauthenticated remote attackers to cause a denial of service by sending specially crafted AVP data with invalid length fields during IKEv2 authentication. The vulnerability arises from failure to validate AVP length fields before subtraction, leading to excessive memory allocation or NULL pointer dereference that crashes the charon IKE daemon.

References

Community reviews

Loading reviews…