Skip to main content
VulnerabilityPublished Updated

CVE-2026-63763: SurrealDB before 2.5.0 and before 3.0.0-beta.3 contains a confused deputy privilege escalation vulnerability

Affects surrealdbSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.5.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade surrealdb/surrealdb to 2.5.0.

Affected software

ProductAffectedFixed in
GitHubsurrealdb/surrealdbpkg:github/surrealdb/surrealdbOther threatsAffected
  • <2.5.0
Fixed in
  • 2.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict unprivileged users from creating or modifying fields that can contain executable elements such as futures, functions, or closures, if possible.

Description

SurrealDB versions before 2.5.0 and before 3.0.0-beta.3 have a confused deputy privilege escalation vulnerability. Unprivileged users with roles such as database editor can create or modify fields containing executable elements like futures, functions, or closures. These elements run with the permissions of the user querying or invoking them, potentially allowing malicious logic to execute with higher privileges. This vulnerability can lead to full privilege escalation, including the creation of a root owner and complete server takeover.

References

Community reviews

Loading reviews…