SurrealDB before 3.3.0 contains an unbounded recursion vulnerability that allows authenticated users to abort the
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 3.3.0 soon.
Data as of 3 Nov 2026, 16:29 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 3.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade surrealdb to 3.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| surrealdbsurrealdb | Affected
| Fixed in
|
crates.iosurrealdbpkg:cargo/surrealdbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in SurrealDB version 3.3.0 and later. Users should upgrade to version 3.3.0 or newer to remediate this vulnerability. No other mitigation or temporary workaround is indicated.
Description
SurrealDB versions prior to 3.3.0 have an unbounded recursion vulnerability that allows authenticated users to cause a stack overflow by creating deeply nested data structures. This can be exploited by repeatedly running UPDATE statements that wrap a stored array within itself, followed by SELECT or EXPORT operations, resulting in a persistent denial of service by aborting the surreald process.