@sylphx/pdf-reader-mcp: HTTP transport accepts unauthenticated requests despite a configured MCP_API_KEY
Affects @sylphx/pdf-reader-mcpSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 3.0.1 soon.
Data as of 29 Oct 2026, 17:21 UTC
- Patch
- Available – fixed in 3.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade @sylphx/pdf-reader-mcp to 3.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@sylphx/pdf-reader-mcp | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to @sylphx/pdf-reader-mcp version 3.0.1 or later, which enforces API key authentication, restricts default binding to localhost, and provides startup warnings for insecure configurations. For environments unable to upgrade immediately, bind the HTTP server to 127.0.0.1 only, place a reverse proxy that enforces authentication in front of the service, use the default stdio transport instead of HTTP, or restrict filesystem access with --allow-dir or MCP_PDF_ALLOWED_DIRS.
Description
The @sylphx/pdf-reader-mcp package, when run as an HTTP server with MCP_TRANSPORT=http, fails to enforce API key authentication despite logging that it does. This allows unauthenticated access to the /mcp endpoint, enabling any client able to reach the server to invoke PDF processing tools and read any accessible PDF files on the host. The default binding to all interfaces (0.0.0.0) increases exposure risk. This vulnerability affects versions >=2.2.0 and <3.0.1 and is fixed in version 3.0.1.
References
- github.com/SylphxAI/pdf-reader-mcp/security/advisories/GHSA-q344-5v34-gm84 (opens in a new tab)
- github.com/SylphxAI/anymd/pull/332 (opens in a new tab)
- github.com/SylphxAI/anymd/commit/4c35f72862d729301e3912ab8c8317d2828cf4c2 (opens in a new tab)
- github.com/SylphxAI/anymd/releases/tag/v3.0.1 (opens in a new tab)
- github.com/SylphxAI/pdf-reader-mcp (opens in a new tab)